Nantes Hardware
Connectes toi !

[NAS] D-Link DNS-320 et DNS-325

Page 3 sur 6 Précédent  1, 2, 3, 4, 5, 6  Suivant

Aller en bas

Re: [NAS] D-Link DNS-320 et DNS-325

Message par mdotam le Mar 24 Jan 2012 - 9:35

Hello, j'arrive comme un cheveux sur la soupe, mais ayant moi aussi acquis le NAS Dlink 325 et suivit toutes les instructions de ce fil, je me retrouve avec la même erreur que mamouth, qu'il a recopier dans son message au dessus de 19h47.

Je cherche, mais tout comme lui je suis DEBUTANT c'est à dire que je n'ai jamais mis ou tenté d'installer linux ou l'une de ses distributions auparavant.

J'ai bien essayé de faire un update & upgrade du noyau linux mais j'ai à nouveau la même erreur que mamouth qui ré-apparait

Quelles infos puis-je vous fournir pour essayer d'avancer ? sachant que je n'ai fais que suivre les tutos d'installation de la première page du thread, que l'installation se déroule nickel pour la première partie.
C'est lorsque j'installe les dépendances comme indiqué dans la partie III)a que le problème se produit :
Code:

Setting up libgcc1 (1:4.6.2-12) ...
FATAL: kernel too old
Segmentation fault
dpkg: error processing libgcc1 (--configure):
 subprocess installed post-installation script returned error exit status 139
configured to not write apport reports
                                      Errors were encountered while processing:
 libgcc1
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install.  Trying to recover:
dpkg: dependency problems prevent configuration of locales:
 locales depends on glibc-2.13-1; however:
  Package glibc-2.13-1 is not installed.
dpkg: error processing locales (--configure):
 dependency problems - leaving unconfigured
Setting up libgcc1 (1:4.6.2-12) ...
FATAL: kernel too old
Segmentation fault
dpkg: error processing libgcc1 (--configure):
 subprocess installed post-installation script returned error exit status 139
Errors were encountered while processing:
 locales
 libgcc1

root@NAS-CK:~#

Merci pour toutes réponses car je commence à en souffrir...

mdotam
Visiteur

Nombre de messages : 8

Revenir en haut Aller en bas

Re: [NAS] D-Link DNS-320 et DNS-325

Message par sioban le Mar 24 Jan 2012 - 10:21

J'ai l'impression que vous n'avez pas bien suivi les instructions pour le keyring multimedia.

Voici ce qu'il faut faire :

Code:
wget http://www.debian-multimedia.org/pool/main/d/debian-multimedia-keyring/debian-multimedia-keyring_2010.12.26_all.deb
dpkg -i http://www.debian-multimedia.org/pool/main/d/debian-multimedia-keyring/debian-multimedia-keyring_2010.12.26_all.deb
apt-get update
apt-get upgrade

et postez le résultat.
avatar
sioban
Coadmin
Coadmin

Nombre de messages : 21040
Localisation : Perdue dans les genres

Revenir en haut Aller en bas

Re: [NAS] D-Link DNS-320 et DNS-325

Message par mdotam le Mar 24 Jan 2012 - 11:19

Code:
root@NAS-CK:/# wget http://www.debian-multimedia.org/pool/main/d/debian-multimedia-keyring/debian-multimedia-keyring_2010.12.26_all.deb
--2012-01-24 11:15:38--  http://www.debian-multimedia.org/pool/main/d/debian-multimedia-keyring/debian-multimedia-keyring_2010.12.26_all.deb
Resolving www.debian-multimedia.org... 91.121.10.104
Connecting to www.debian-multimedia.org|91.121.10.104|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 15094 (15K) [application/x-debian-package]
Saving to: `debian-multimedia-keyring_2010.12.26_all.deb'

100%[=================================================>] 15,094      --.-K/s  in 0.06s

2012-01-24 11:15:38 (254 KB/s) - `debian-multimedia-keyring_2010.12.26_all.deb' saved [15094/15094]

root@NAS-CK:/# dpkg -i http://www.debian-multimedia.org/pool/main/d/debian-multimedia-keyring/debian-multimedia-keyring_2010.12.26_all.deb
dpkg: error processing http://www.debian-multimedia.org/pool/main/d/debian-multimedia-keyring/debian-multimedia-keyring_2010.12.26_all.deb (--install):
 cannot access archive: No such file or directory
Errors were encountered while processing:
 http://www.debian-multimedia.org/pool/main/d/debian-multimedia-keyring/debian-multimedia-keyring_2010.12.26_all.deb

en parallèle j'ai refais l'install de squeeze mais avant de lancer l'update et l'upgrade je n'ai gardé dans mon fichier sources.list que les liens vers squeeze, j'ai lancé aptitude install && aptitude upgrade tout s'est bien déroulé, la commande make marche cette fois ci, mais avec une erreur car il manque un fichier, peut-être lier à ce que vous décrivez au dessus, je vous laisse donc le résultat de cet essai, en tout les cas merci.
Code:
root@NAS-CK:/tmp/minidlna-1.0.22# make
./genconfig.sh
-e
ERROR!  Cannot continue.
-e The following required libraries are either missing, or are missing development headers:

-e libavcodec libavutil

make: *** [config.h] Error 1
root@NAS-CK:/tmp/minidlna-1.0.22#


Dernière édition par mdotam le Mar 24 Jan 2012 - 11:26, édité 1 fois
avatar
mdotam
Visiteur

Nombre de messages : 8
Localisation : Frontignan

Revenir en haut Aller en bas

Re: [NAS] D-Link DNS-320 et DNS-325

Message par sioban le Mar 24 Jan 2012 - 11:22

oups désolé je corrige :

Code:
wget http://www.debian-multimedia.org/pool/main/d/debian-multimedia-keyring/debian-multimedia-keyring_2010.12.26_all.deb
dpkg -i debian-multimedia-keyring_2010.12.26_all.deb
apt-get update
apt-get upgrade
avatar
sioban
Coadmin
Coadmin

Nombre de messages : 21040
Localisation : Perdue dans les genres

Revenir en haut Aller en bas

Re: [NAS] D-Link DNS-320 et DNS-325

Message par monster le Mar 24 Jan 2012 - 11:23

Il y a une petite coquille, il faut faire un
Code:
dpkg -i debian-multimedia-keyring_2010.12.26_all.deb
et non un
Code:
dpkg -i http://www.debian-multimedia.org/pool/main/d/debian-multimedia-keyring/debian-multimedia-keyring_2010.12.26_all.deb

EDIT: Devancé ^^
avatar
monster
NHFR All Stars
NHFR All Stars

Nombre de messages : 9081
Localisation : sainte pazanne

http://www.yark.fr/

Revenir en haut Aller en bas

Re: [NAS] D-Link DNS-320 et DNS-325

Message par mdotam le Mar 24 Jan 2012 - 11:31

C'est pas grave 2 réponses au lieu de rien c'est quand même tip top Smile, bon après correction de la coquille j'ai réussit à lancer les commandes, mais je me retrouve à nouveau avec :
Code:
root@NAS-CK:/tmp/minidlna-1.0.22# make
./genconfig.sh
-e
ERROR!  Cannot continue.
-e The following required libraries are either missing, or are missing development headers:

-e libavcodec libavutil

make: *** [config.h] Error 1
root@NAS-CK:/tmp/minidlna-1.0.22#
ce que contient mon fichier genconfig.sh
Code:
#! /bin/sh
# $Id: genconfig.sh,v 1.20 2011/02/17 23:17:24 jmaggard Exp $
# MiniDLNA project
# http://sourceforge.net/projects/minidlna/
#
# MiniDLNA media server
# Copyright (C) 2008-2009  Justin Maggard
#
# This file is part of MiniDLNA.
#
# MiniDLNA is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License version 2 as
# published by the Free Software Foundation.
#
# MiniDLNA is distributed in the hope that it will be useful,
# but WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
# GNU General Public License for more details.
#
# You should have received a copy of the GNU General Public License
# along with MiniDLNA. If not, see <http://www.gnu.org/licenses/>.

RM="rm -f"
CONFIGFILE="config.h"
CONFIGMACRO="__CONFIG_H__"

# Database path
DB_PATH="/tmp/minidlna"
# Log path
LOG_PATH="${DB_PATH}"

# detecting the OS name and version
OS_NAME=`uname -s`
OS_VERSION=`uname -r`
TIVO="/*#define TIVO_SUPPORT*/"
NETGEAR="/*#define NETGEAR*/"
READYNAS="/*#define READYNAS*/"
PNPX="#define PNPX 0"

${RM} ${CONFIGFILE}

# Detect if there are missing headers
# NOTE: This check only works with a normal distro
[ ! -e "/usr/include/sqlite3.h" ] && MISSING="libsqlite3 $MISSING"
[ ! -e "/usr/include/jpeglib.h" ] && MISSING="libjpeg $MISSING"
[ ! -e "/usr/include/libexif/exif-loader.h" ] && MISSING="libexif $MISSING"
[ ! -e "/usr/include/id3tag.h" ] && MISSING="libid3tag $MISSING"
[ ! -e "/usr/include/ogg/ogg.h" ] && MISSING="libogg $MISSING"
[ ! -e "/usr/include/vorbis/codec.h" ] && MISSING="libvorbis $MISSING"
[ ! -e "/usr/include/FLAC/metadata.h" ] && MISSING="libflac $MISSING"
[ ! -e "/usr/include/ffmpeg/avutil.h" -a \
  ! -e "/usr/include/libavutil/avutil.h" -a \
  ! -e "/usr/include/ffmpeg/libavutil/avutil.h" ] && MISSING="libavutil $MISSING"
[ ! -e "/usr/include/ffmpeg/avformat.h" -a \
  ! -e "/usr/include/libavformat/avformat.h" -a \
  ! -e "/usr/include/ffmpeg/libavformat/avformat.h" ] && MISSING="libavformat $MISSING"
[ ! -e "/usr/include/ffmpeg/avcodec.h" -a \
  ! -e "/usr/include/libavcodec/avcodec.h" -a \
  ! -e "/usr/include/ffmpeg/libavcodec/avcodec.h" ] && MISSING="libavcodec $MISSING"
if [ -n "$MISSING" ]; then
   echo -e "\nERROR!  Cannot continue."
   echo -e "The following required libraries are either missing, or are missing development headers:\n"
   echo -e "$MISSING\n"
   exit 1
fi

echo "/* MiniDLNA Project" >> ${CONFIGFILE}
echo " * http://sourceforge.net/projects/minidlna/" >> ${CONFIGFILE}
echo " * (c) 2008-2009 Justin Maggard" >> ${CONFIGFILE}
echo " * generated by $0 on `date` */" >> ${CONFIGFILE}
echo "#ifndef $CONFIGMACRO" >> ${CONFIGFILE}
echo "#define $CONFIGMACRO" >> ${CONFIGFILE}
echo "" >> ${CONFIGFILE}

# OS Specific stuff
case $OS_NAME in
   OpenBSD)
      MAJORVER=`echo $OS_VERSION | cut -d. -f1`
      MINORVER=`echo $OS_VERSION | cut -d. -f2`
      #echo "OpenBSD majorversion=$MAJORVER minorversion=$MINORVER"
      # rtableid was introduced in OpenBSD 4.0
      if [ $MAJORVER -ge 4 ]; then
         echo "#define PFRULE_HAS_RTABLEID" >> ${CONFIGFILE}
      fi
      # from the 3.8 version, packets and bytes counters are double : in/out
      if [ \( $MAJORVER -ge 4 \) -o \( $MAJORVER -eq 3 -a $MINORVER -ge 8 \) ]; then
         echo "#define PFRULE_INOUT_COUNTS" >> ${CONFIGFILE}
      fi
      OS_URL=http://www.openbsd.org/
      ;;
   FreeBSD)
      VER=`grep '#define __FreeBSD_version' /usr/include/sys/param.h | awk '{print $3}'`
      if [ $VER -ge 700049 ]; then
         echo "#define PFRULE_INOUT_COUNTS" >> ${CONFIGFILE}
      fi
      OS_URL=http://www.freebsd.org/
      ;;
   pfSense)
      # we need to detect if PFRULE_INOUT_COUNTS macro is needed
      OS_URL=http://www.pfsense.com/
      ;;
   NetBSD)
      OS_URL=http://www.netbsd.org/
      ;;
   SunOS)
      echo "#define USE_IPF 1" >> ${CONFIGFILE}
      echo "#define LOG_PERROR 0" >> ${CONFIGFILE}
      echo "#define SOLARIS_KSTATS 1" >> ${CONFIGFILE}
      echo "typedef uint64_t u_int64_t;" >> ${CONFIGFILE}
      echo "typedef uint32_t u_int32_t;" >> ${CONFIGFILE}
      echo "typedef uint16_t u_int16_t;" >> ${CONFIGFILE}
      echo "typedef uint8_t u_int8_t;" >> ${CONFIGFILE}
      OS_URL=http://www.sun.com/solaris/
      ;;
   Linux)
      OS_URL=http://www.kernel.org/
      KERNVERA=`echo $OS_VERSION | awk -F. '{print $1}'`
      KERNVERB=`echo $OS_VERSION | awk -F. '{print $2}'`
      KERNVERC=`echo $OS_VERSION | awk -F. '{print $3}'`
      KERNVERD=`echo $OS_VERSION | awk -F. '{print $4}'`
      #echo "$KERNVERA.$KERNVERB.$KERNVERC.$KERNVERD"
      # NETGEAR ReadyNAS special case
      if [ -f /etc/raidiator_version ]; then
         OS_NAME=$(awk -F'!!|=' '{ print $1 }' /etc/raidiator_version)
         OS_VERSION=$(awk -F'!!|[=,.]' '{ print $3"."$4 }' /etc/raidiator_version)
         OS_URL="http://www.readynas.com/"
         LOG_PATH="/var/log"
         DB_PATH="/var/cache/minidlna"
         TIVO="#define TIVO_SUPPORT"
         NETGEAR="#define NETGEAR"
         READYNAS="#define READYNAS"
         PNPX="#define PNPX 5"
      # Debian GNU/Linux special case
      elif [ -f /etc/debian_version ]; then
         OS_NAME=Debian
         OS_VERSION=`cat /etc/debian_version`
         OS_URL=http://www.debian.org/
         LOG_PATH="/var/log"
         # use lsb_release (Linux Standard Base) when available
         LSB_RELEASE=`which lsb_release 2>/dev/null`
         if [ 0 -eq $? ]; then
            OS_NAME=`${LSB_RELEASE} -i -s`
            OS_VERSION=`${LSB_RELEASE} -r -s`
         fi
      else
         # use lsb_release (Linux Standard Base) when available
         LSB_RELEASE=`which lsb_release 2>/dev/null`
         if [ 0 -eq $? ]; then
            OS_NAME=`${LSB_RELEASE} -i -s`
            OS_VERSION=`${LSB_RELEASE} -r -s`
         fi
      fi
      ;;
   *)
      echo "Unknown OS : $OS_NAME"
      exit 1
      ;;
esac

echo "#define OS_NAME         \"$OS_NAME\"" >> ${CONFIGFILE}
echo "#define OS_VERSION      \"$OS_NAME/$OS_VERSION\"" >> ${CONFIGFILE}
echo "#define OS_URL         \"${OS_URL}\"" >> ${CONFIGFILE}
echo "" >> ${CONFIGFILE}

echo "/* full path of the file database */" >> ${CONFIGFILE}
echo "#define DEFAULT_DB_PATH      \"${DB_PATH}\"" >> ${CONFIGFILE}
echo "" >> ${CONFIGFILE}

echo "/* full path of the log directory */" >> ${CONFIGFILE}
echo "#define DEFAULT_LOG_PATH   \"${LOG_PATH}\"" >> ${CONFIGFILE}
echo "" >> ${CONFIGFILE}

echo "/* Comment the following line to use home made daemonize() func instead" >> ${CONFIGFILE}
echo " * of BSD daemon() */" >> ${CONFIGFILE}
echo "#define USE_DAEMON" >> ${CONFIGFILE}
echo "" >> ${CONFIGFILE}

echo "/* Enable if the system inotify.h exists.  Otherwise our own inotify.h will be used. */" >> ${CONFIGFILE}
if [ -f /usr/include/sys/inotify.h ]; then
echo "#define HAVE_INOTIFY_H" >> ${CONFIGFILE}
else
echo "/*#define HAVE_INOTIFY_H*/" >> ${CONFIGFILE}
fi
echo "" >> ${CONFIGFILE}

echo "/* Enable if the system iconv.h exists.  ID3 tag reading in various character sets will not work properly otherwise. */" >> ${CONFIGFILE}
if [ -f /usr/include/iconv.h ]; then
echo "#define HAVE_ICONV_H" >> ${CONFIGFILE}
else
echo -e "\nWARNING!!  Iconv support not found.  ID3 tag reading may not work."
echo "/*#define HAVE_ICONV_H*/" >> ${CONFIGFILE}
fi
echo "" >> ${CONFIGFILE}

echo "/* Enable if the system libintl.h exists for NLS support. */" >> ${CONFIGFILE}
if [ -f /usr/include/libintl.h ]; then
echo "#define ENABLE_NLS" >> ${CONFIGFILE}
else
echo "/*#define ENABLE_NLS*/" >> ${CONFIGFILE}
fi
echo "" >> ${CONFIGFILE}

echo "/* Enable NETGEAR-specific tweaks. */" >> ${CONFIGFILE}
echo "${NETGEAR}" >> ${CONFIGFILE}
echo "/* Enable ReadyNAS-specific tweaks. */" >> ${CONFIGFILE}
echo "${READYNAS}" >> ${CONFIGFILE}
echo "/* Compile in TiVo support. */" >> ${CONFIGFILE}
echo "${TIVO}" >> ${CONFIGFILE}
echo "/* Enable PnPX support. */" >> ${CONFIGFILE}
echo "${PNPX}" >> ${CONFIGFILE}
echo "" >> ${CONFIGFILE}

echo "#endif" >> ${CONFIGFILE}

exit 0
avatar
mdotam
Visiteur

Nombre de messages : 8
Localisation : Frontignan

Revenir en haut Aller en bas

Re: [NAS] D-Link DNS-320 et DNS-325

Message par sioban le Mar 24 Jan 2012 - 11:36

Tu as fait ça ? Point III.A.a)

Code:
aptitude install build-essential libexif-dev libjpeg-dev libid3tag0-dev libflac-dev libvorbis-dev libsqlite3-dev libavformat-dev libuuid1
avatar
sioban
Coadmin
Coadmin

Nombre de messages : 21040
Localisation : Perdue dans les genres

Revenir en haut Aller en bas

Re: [NAS] D-Link DNS-320 et DNS-325

Message par sioban le Mar 24 Jan 2012 - 11:39

Je dis ça car la solution que j'apporte plus haut ne règle QUE le point de blocage sur les clés manquantes pour le point II.b

Cela ne dispense pas des actions suivantes...
avatar
sioban
Coadmin
Coadmin

Nombre de messages : 21040
Localisation : Perdue dans les genres

Revenir en haut Aller en bas

Re: [NAS] D-Link DNS-320 et DNS-325

Message par mdotam le Mar 24 Jan 2012 - 11:44

je l'ai fais mais j'ai :
Code:
root@NAS-CK:/tmp# aptitude install build-essential libexif-dev libjpeg-dev libid3tag0-dev libflac-dev libvorbis-dev libsqlite3-dev libavformat-dev libuuid1
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B of archives. After unpacking 0 B will be used.
Ca ne semble pas avoir modifier l'install du packaging, en revanche quand je regarde dans mon fichier genconfig.sh je remarque qu'à l'emplacement désigné je n'ai pas de répertoire /usr/ffmpeg et donc encore moins de avutil.h je suppose que c'est lié à mon fichier sources.list dans lequel j'ai volontairement limité l'accès à trop de sources, je vais y ajouter les lignes sources multimédia et relancer l'install et l'update.
Je vous tiens au courant avant de pourrir plus le thread avec des questions qui ne devraient pas avoir lieu d'être.
Merci.
avatar
mdotam
Visiteur

Nombre de messages : 8
Localisation : Frontignan

Revenir en haut Aller en bas

Re: [NAS] D-Link DNS-320 et DNS-325

Message par monster le Mar 24 Jan 2012 - 11:52

Le détail du source.list est en première page, il faut bien tout mettre, pour avoir les paquets nécessaire.
avatar
monster
NHFR All Stars
NHFR All Stars

Nombre de messages : 9081
Localisation : sainte pazanne

http://www.yark.fr/

Revenir en haut Aller en bas

Re: [NAS] D-Link DNS-320 et DNS-325

Message par mdotam le Mar 24 Jan 2012 - 12:00

monster a écrit:Le détail du source.list est en première page, il faut bien tout mettre, pour avoir les paquets nécessaire.
salut, en fait si je met tout les liens je me retrouve avec l'impossibilité de lancer la commande make comme indiqué par mamouth, mais si je ne met que les liens vers squeeze la commande cette fois se lance, alors je veux bien ajouter les sources au fur et à mesure, mais je suis sur que si je les mets toutes d'un seul coup ça ne marche pas (c'est déjà la 3eme fois que je réinstalle depuis le début), je dis pas que je sais ce que je fais mais force est de constater qu'en suivant à la lettre le tuto on aboutit à l'erreur décrite par mamouth.

Si il me manque des dépendances ou autre ce sera peut-être plus facile à télécharger à part que d'ajouter des liens dans mon sources.list qui viens me perturber après un aptitude update le bon déroulement des opérations indiqués dans le tuto.
(en même temps mon niveau 0 ne me permet pas d'affirmer avec certitude ça).

Edit : bon ben voilà dès que j'ajoute dans mon sources.list les lignes wheezy & sid (j'aurais pas du y mettre les 2 d'un seul coup) et que je relance aptitude update && aptitude upgrade, j'ai des dizaines d'erreurs que je n'avais pas lorsque je n'avais que les lignes pointant vers les depôts de squeeze :/


Dernière édition par mdotam le Mar 24 Jan 2012 - 12:06, édité 1 fois
avatar
mdotam
Visiteur

Nombre de messages : 8
Localisation : Frontignan

Revenir en haut Aller en bas

Re: [NAS] D-Link DNS-320 et DNS-325

Message par monster le Mar 24 Jan 2012 - 12:03

Tout a bien été effacé dans le fichier source.list avant de tout y insérer ?
avatar
monster
NHFR All Stars
NHFR All Stars

Nombre de messages : 9081
Localisation : sainte pazanne

http://www.yark.fr/

Revenir en haut Aller en bas

Re: [NAS] D-Link DNS-320 et DNS-325

Message par mdotam le Mar 24 Jan 2012 - 12:10

J'aimerai avoir une précision par rapport au tuto, dans la partie lien utile tout ce qui est compris dans l'installation de
funpkg : http://nas-tweaks.net/82/installing-and-uninstalling-packages-and-activation-and-deactivation-of-daemons-in-fonz-fun_plug/
ipkg via optware : http://nas-tweaks.net/219/installation-of-optware-on-the-d-link-dns-320-dns-325-dns-343-and-conceptronic-ch3mnas/

cette partie est installé sous ffp et n'a rien avoir avec squeeze ou les 2 lignes d'installations sont nécessaires ?

j'explique comment je l'interpréte, c'est qu'une fois que l'on a rebooté sous fun_plug(debian) ces installs sont sous le répertoire ffp et non pas squeeze je n'y vois donc pas d'utilité pour la suite de l'installation de minidlna car aucun appel n'est fait vers ce répertoire (enfin moi j'en vois pas), si j'explique mal voir très mal n'hésitez pas à me faire préciser ma pensée ou éclaircir ce que je peine à décrire...

Alors un tout petit résumé de ce que j'ai fais :

J'ai viré le répertoire squeeze puis j'ai à nouveau dézippé puis réinstaller squeeze.tar.gz, ensuite, dans sources.list j'ai viré toutes lignes autres que celles qui pointé vers squeeze, lancez les install/update/upgrade aucune erreurs, tout (il faut comprendre par là en suivant le déroulement du tuto étape par étape) s'est correctement déroulé jusqu'à la commande make qui cette fois se lance mais qui m'indique une erreur car il me manque des library qui n'ont pas été installé mais je ne sais pas à partir de quelle commande celles ci auraient du l'être.

Bref dans le doute j'ai ajouté les lignes wheezy et sid dans mon fichier sources.list puis relancé install/update/upgrade et là je me suis retrouvé avec beaucoup d'erreurs (alors que juste avant je n'en avais aucune) mais cela ne m'a pas installé ces 2 libs qui sont libavcodec (qui aurait du être dans /usr/config/ffmpeg je ne sais pas quelle est la commande qui aurait du lancer la récupération est l'installation de ces 2 library (bibliothèques): libavcodec libavutil.

Bon j'ai renommé mon répertoire squeeze et je retente une installation, je connais(sais) rien à linux mais les problèmes d'installations ça forme (un peu) Sad
avatar
mdotam
Visiteur

Nombre de messages : 8
Localisation : Frontignan

Revenir en haut Aller en bas

Re: [NAS] D-Link DNS-320 et DNS-325

Message par mdotam le Mar 24 Jan 2012 - 14:57

Pour info, je suis donc reparti de zéro (en considérant que mon installation de fonz plug s'est bien déroulé), et bien maintenant ça fonctionne correctement, mais surtout à aucun moment je n'ai updaté mon fichier sources.list - qui est comme précisé insuffisant, en tout les cas pour l'installation sans erreurs c'est bien à partir de cette source que cela fonctionne correctement, j'ajouterai les autres liens dans mon fichier une fois que je me serai assuré que tout est ok, puis je ferai une copie du répertoire et ensuite lancerai un update et un upgrade histoire d'aller au bout.

MERCI Smile AUX 2 PERSONNES QUI ONT PRIS LE TEMPS DE ME REPONDRE.

Edit :

L'installation s'est bien déroulé, mais pour pouvoir profiter, gérer ce serveur comme indiqué à la fin dans le lien de http://www.galipe.net/articles/minidlna-serveur-upnp-dlna-leger/ est-ce que quelqu'un peut m'indiquer comment j'installe les modules minidlnawebmin et webmin, et éventuellement comment je m'y connecte, Merci.
est-ce que ça s'installe en ligne de commandes sous putty ou via un autre biais ?
Edit 2: ok c'est bon j'ai trouvé ça ici http://www.webmin.com/deb.html
avatar
mdotam
Visiteur

Nombre de messages : 8
Localisation : Frontignan

Revenir en haut Aller en bas

Re: [NAS] D-Link DNS-320 et DNS-325

Message par deepqck le Mar 24 Jan 2012 - 19:25

Bonsoir,

Je remonte le sujet. Je possède un D-Link DNS 323 et j'ai pu voir que certains avaient réussi à installer "sabnzbd" avec succès. Pour ma part je ni parviens pas.
Pourrais t'on me dire la marche à suivre?
Pour info j'ai déjà Fun_Plug .. Je peux me connecter en telnet .. En revanche lorsque j'ai mis en place la distribution "Debian Squeeze" dessus, impossible de me connecter en telnet ou SSH donc impossible de continuer l'installation de ce grabber :/

J'ai pourtant suivi à la lettre .. Je précise que mon fun_plug je l'ai depuis longtemps et ça à toujours fonctionner pour mes packs langues, client torrent ...

Merci par avance !
avatar
deepqck
Visiteur

Nombre de messages : 16
Localisation : France

Revenir en haut Aller en bas

Re: [NAS] D-Link DNS-320 et DNS-325

Message par robin44 le Mar 24 Jan 2012 - 19:41

Debian Squeeze sur un DNS-323 ? Hum comment dire, vu le peu de RAM qu'à ce NAS ce n'est pas une bonne idée. Maintenant tu peux très bien installer Sabnzb sous ffp comme suit:
Code:
#ipkg install sabnzbdplus
#ipkg install py25-openssl
#ipkg install unrar
#ipkg install unzip

Rajouter ces entrées dans le fichier /ffp/etc/fun_plug.init :
Code:
#!/ffp/bin/sh
PATH=/ffp/sbin:/ffp/bin:/usr/sbin:/sbin:/usr/bin:/bin
 
# Create symbolic link /mnt/HD_a2 to point to /mnt/HD/HD_a2
ln -snf /mnt/HD/HD_a2 /mnt/HD_a2
 
#par2 symbolic links for opt/sabnzbd
ln -snf /opt/bin/par2 /bin/par2
ln -snf /opt/bin/unrar /bin/unrar
ln -snf /opt/bin/unzip /bin/unzip

Ensuite, créer un répertoire « downloads » avec à l’intérieur « complets », « incomplets », « imported » puis un autre répertoire « nzb » dans /mnt/HD/HD_a2 par exemple, vous pouvez très bien changer ces répertoires comme bon vous semble, puis rajouter ces liens symbolique dans /ffp/etc/fun_plug.init :
Code:
ln –s /mnt/HD/HD_a2/downloads / /downloads
ln –s /mnt/HD/HD_a2/nzb/ /nzb

Enfin, configurer Sabnzbd+ en se connectant sur l'interface: http://ipdunas:8080/sabnzbd

Personnellement je préfère utiliser nzbget qui est plus léger et donc prend très peu de ressources.

mdotam a écrit:Pour info, je suis donc reparti de zéro (en considérant que mon installation de fonz plug s'est bien déroulé), et bien maintenant ça fonctionne correctement, mais surtout à aucun moment je n'ai updaté mon fichier sources.list - qui est comme précisé insuffisant, en tout les cas pour l'installation sans erreurs c'est bien à partir de cette source que cela fonctionne correctement, j'ajouterai les autres liens dans mon fichier une fois que je me serai assuré que tout est ok, puis je ferai une copie du répertoire et ensuite lancerai un update et un upgrade histoire d'aller au bout.

MERCI Smile AUX 2 PERSONNES QUI ONT PRIS LE TEMPS DE ME REPONDRE.

Edit :

L'installation s'est bien déroulé, mais pour pouvoir profiter, gérer ce serveur comme indiqué à la fin dans le lien de http://www.galipe.net/articles/minidlna-serveur-upnp-dlna-leger/ est-ce que quelqu'un peut m'indiquer comment j'installe les modules minidlnawebmin et webmin, et éventuellement comment je m'y connecte, Merci.
est-ce que ça s'installe en ligne de commandes sous putty ou via un autre biais ?
Edit 2: ok c'est bon j'ai trouvé ça ici http://www.webmin.com/deb.html

pour ceux que ça intéresse voici maintenant comment compiler votre propre miniDLNA (version CVS):

Prérequis: Il faut installer autoconf, automake et gettext puis,

Code:
cd /ffp/tmp ou cd /tmp pour Squeeze
cvs -d:pserver:anonymous@minidlna.cvs.sourceforge.net:/cvsroot/minidlna login
cvs -z3 -d:pserver:anonymous@minidlna.cvs.sourceforge.net:/cvsroot/minidlna co -P minidlna
cd minidlna
./autogen.sh
./configure
make

puis recopier le binaire dans le bon répertoire (/ffp/opt/optware/sbin pour ffp et /usr/sbin pour Squeeze)

Voilà, cela vous permettra d'avoir la dernière version CVS en date Wink

edit: ajout de l'installation de Pyload dans les tutos du post initial.


Dernière édition par robin44 le Mar 24 Jan 2012 - 20:23, édité 1 fois
avatar
robin44
Modérateur
Modérateur

Nombre de messages : 6577
Localisation : Missillac

Revenir en haut Aller en bas

Re: [NAS] D-Link DNS-320 et DNS-325

Message par deepqck le Mar 24 Jan 2012 - 20:13

Merci !!!

Ben si tu me conseille nzbget et qu'un tuto est dispo je prend de suite !!

En tout cas merci beaucoup, j'ai chercher de partout et j'ai rien trouvé de concret ..
Je suis même tomber sur une doc en Allemand mais bon j'ai pas compris ^^ !

Edit: Je me suis tourné vers Squeeze par désespoir, vue que je trouvé rien d'autre .. Mais je ne m'attendais pas à un miracle ..; Vue la petite config du DNS 323 ^^
avatar
deepqck
Visiteur

Nombre de messages : 16
Localisation : France

Revenir en haut Aller en bas

Re: [NAS] D-Link DNS-320 et DNS-325

Message par robin44 le Mar 24 Jan 2012 - 20:21

Pour nzbget sous ffp (via optware) c'est ici: http://nzbget.sourceforge.net/Installation_on_Optware

Wink
avatar
robin44
Modérateur
Modérateur

Nombre de messages : 6577
Localisation : Missillac

Revenir en haut Aller en bas

Re: [NAS] D-Link DNS-320 et DNS-325

Message par deepqck le Mar 24 Jan 2012 - 20:23

Merci, j'essaye je tiens au courant !!

avatar
deepqck
Visiteur

Nombre de messages : 16
Localisation : France

Revenir en haut Aller en bas

Re: [NAS] D-Link DNS-320 et DNS-325

Message par deepqck le Mar 24 Jan 2012 - 20:24

/ # /ffp/bin/sh: ipkg: not found

Ca commence mal .. J'ai plus qu'a retrouvé les ressources ..;

Un lien m'aiderais étant donné que le wiki sur le dns 323 est dead ..

Edit: Je suis en train de remettre Fun plug en place

Edit2: Je lis qu'il faut un serv php pour ce grabber .. arf .. sabnzbd aussi ?
avatar
deepqck
Visiteur

Nombre de messages : 16
Localisation : France

Revenir en haut Aller en bas

Re: [NAS] D-Link DNS-320 et DNS-325

Message par deepqck le Mar 24 Jan 2012 - 21:10

Je suis en train de me prendre la tête pour installer un serveur web ..

Ni a t-il donc aucune ressource fiable !!! :@
avatar
deepqck
Visiteur

Nombre de messages : 16
Localisation : France

Revenir en haut Aller en bas

Re: [NAS] D-Link DNS-320 et DNS-325

Message par deepqck le Mar 24 Jan 2012 - 21:35

Bon le serveur web c'est bon ..
Je peu up direct dans repertoire page des fichiers et je les vois.

Par contre le client sabnzbd j'ai un 404 not found.

Je suppose qu'il faut lancer le client !
Dans fftp/start/
Il li a pas de ;sh me permettant de le lancer !!

Help !! Merci
avatar
deepqck
Visiteur

Nombre de messages : 16
Localisation : France

Revenir en haut Aller en bas

Re: [NAS] D-Link DNS-320 et DNS-325

Message par sioban le Mar 24 Jan 2012 - 21:55

euh sabnzbdplus est vraiment très bien, je vois pas ce que tu lui repproches !
avatar
sioban
Coadmin
Coadmin

Nombre de messages : 21040
Localisation : Perdue dans les genres

Revenir en haut Aller en bas

Re: [NAS] D-Link DNS-320 et DNS-325

Message par deepqck le Mar 24 Jan 2012 - 22:01

Au passage je précise que j'ai aussi test avec nzbget et c'est sans succes ..
avatar
deepqck
Visiteur

Nombre de messages : 16
Localisation : France

Revenir en haut Aller en bas

Re: [NAS] D-Link DNS-320 et DNS-325

Message par deepqck le Mar 24 Jan 2012 - 22:01

Sioban, comment lances tu sabnzbd ??

merci
avatar
deepqck
Visiteur

Nombre de messages : 16
Localisation : France

Revenir en haut Aller en bas

Re: [NAS] D-Link DNS-320 et DNS-325

Message par sioban le Mar 24 Jan 2012 - 22:03

il n'y a pas besoin qu'un fichier soit nommé ".sh" pour être lancé :
chmod +x fichier
./fichier

mais oui il faut php pour ces deux là puisqu'ils fonctionnent avec une interface web en php
avatar
sioban
Coadmin
Coadmin

Nombre de messages : 21040
Localisation : Perdue dans les genres

Revenir en haut Aller en bas

Re: [NAS] D-Link DNS-320 et DNS-325

Message par Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Page 3 sur 6 Précédent  1, 2, 3, 4, 5, 6  Suivant

Revenir en haut


 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum