Nantes Hardware
Connectes toi !

[OpenSuse13.1] Pilote réseau manquant ?

Aller en bas

[OpenSuse13.1] Pilote réseau manquant ? Empty [OpenSuse13.1] Pilote réseau manquant ?

Message par Remuald le Ven 17 Jan 2014 - 19:29

Hello,

J'ai récemment installé un OpenSuse 13.1 pour remplacer un Windows XP "mourrant" XD sur une EEE BOX.
Mais je me suis confronté à un problème, je ne parviens pas à trouver un pilote pour la carte réseau JMicron JMC250 compatible avec OpenSuse Sad.

Si vous avez une solution, je suis preneur Very Happy.

PS : j'ai essayé avec le pilote officiel : ftp://driver.jmicron.com.tw/Ethernet/Linux/ mais je n'arrive pas à effectuer le make install (il ne reconnait pas le fichier).
Remuald
Remuald
Coadmin
Coadmin

Nombre de messages : 31630
Localisation : anywhere

Revenir en haut Aller en bas

[OpenSuse13.1] Pilote réseau manquant ? Empty Re: [OpenSuse13.1] Pilote réseau manquant ?

Message par monster le Ven 17 Jan 2014 - 22:22

Même lors de l'installation ça n'a pas voulu avec des pilotes génériques ?

Ca fait longtemps que je n'ai pas essayé Suse (en Open pas du tout de Entreprise).
monster
monster
NHFR All Stars
NHFR All Stars

Nombre de messages : 9129
Localisation : sainte pazanne

http://www.yark.fr/

Revenir en haut Aller en bas

[OpenSuse13.1] Pilote réseau manquant ? Empty Re: [OpenSuse13.1] Pilote réseau manquant ?

Message par Remuald le Ven 17 Jan 2014 - 22:33

Visiblement non. Sad
Je pourrais les réinstaller éventuellement, mais je ne sais pas comment on fait ^^ ?
Remuald
Remuald
Coadmin
Coadmin

Nombre de messages : 31630
Localisation : anywhere

Revenir en haut Aller en bas

[OpenSuse13.1] Pilote réseau manquant ? Empty Re: [OpenSuse13.1] Pilote réseau manquant ?

Message par monster le Ven 17 Jan 2014 - 23:19

Avec le gestionnaire de package Yast il me semble (si je ne me trompe pas ^^')
monster
monster
NHFR All Stars
NHFR All Stars

Nombre de messages : 9129
Localisation : sainte pazanne

http://www.yark.fr/

Revenir en haut Aller en bas

[OpenSuse13.1] Pilote réseau manquant ? Empty Re: [OpenSuse13.1] Pilote réseau manquant ?

Message par sioban le Sam 18 Jan 2014 - 9:48

Les drivers sont inclus dans le noyau normalement.

concernant la compilation c'est quoi le message d'erreur exact ?
tu as bien les headers pour ton kernel ?

Perso j'aime pas suse...
sioban
sioban
Coadmin
Coadmin

Nombre de messages : 21059
Localisation : Perdue dans les genres

Revenir en haut Aller en bas

[OpenSuse13.1] Pilote réseau manquant ? Empty Re: [OpenSuse13.1] Pilote réseau manquant ?

Message par sioban le Sam 18 Jan 2014 - 9:56

en revanche un ptit dmesg après boot et tu nous postes le contenu pourrait nous aider à voir l'erreur, il se peut que le driver soit blacklisté.

que dit un modprobe -v jme ?
s'il dit que le module n'existe pas, peux-tu faire un ls /lib/modules//kernel/drivers/net/ethernet ?
sioban
sioban
Coadmin
Coadmin

Nombre de messages : 21059
Localisation : Perdue dans les genres

Revenir en haut Aller en bas

[OpenSuse13.1] Pilote réseau manquant ? Empty Re: [OpenSuse13.1] Pilote réseau manquant ?

Message par Remuald le Sam 18 Jan 2014 - 12:16

Je n'ai pas la machine sous les yeux, mais de mémoire le modprobe -v jme ne fonctionnait pas.

J'essaierais de voir le ls /lib/modules//kernel/drivers/net/ethernet.
Remuald
Remuald
Coadmin
Coadmin

Nombre de messages : 31630
Localisation : anywhere

Revenir en haut Aller en bas

[OpenSuse13.1] Pilote réseau manquant ? Empty Re: [OpenSuse13.1] Pilote réseau manquant ?

Message par sioban le Sam 18 Jan 2014 - 13:14

entre les deux / (//) il y a le numéro du noyau (c'est pas passé dans mon précédant message)
sioban
sioban
Coadmin
Coadmin

Nombre de messages : 21059
Localisation : Perdue dans les genres

Revenir en haut Aller en bas

[OpenSuse13.1] Pilote réseau manquant ? Empty Re: [OpenSuse13.1] Pilote réseau manquant ?

Message par Remuald le Sam 25 Jan 2014 - 19:29

sioban a écrit:en revanche un ptit dmesg après boot et tu nous postes le contenu pourrait nous aider à voir l'erreur, il se peut que le driver soit blacklisté.

que dit un modprobe -v jme ?
s'il dit que le module n'existe pas, peux-tu faire un ls /lib/modules//kernel/drivers/net/ethernet ?
Avec la commande dmesg j'ai :
https://sd-1.archive-host.com/membres/up/1602262418/NHFR/dmesg.txt

Avec la commande modprobe -v jme :
Code:
sudo: modprobe: command not found

Avec la commande ls /lib/modules/3.11.6-4-desktop/kernel/drivers/net/ethernet, j'obtiens :
Code:
3com
8390
adaptec
alteon
amd
atheros
broadcom
brocade
cadence
calxeda
chelsio
cisco
dec
dlink
dnet.ko
emulex
ethoc.ko
fealnx.ko
fujistu
hp
icplus
intel
jme.ko
marvell
mellanox
micrel
myricom
natsemi
neterion
nvidia
oki-semi
packetengines
qlogic
rdc
realtek
renesas
sfc
silan
sis
smsc
stmicro
sun
tehuti
ti
via
wiznet
xircom
Remuald
Remuald
Coadmin
Coadmin

Nombre de messages : 31630
Localisation : anywhere

Revenir en haut Aller en bas

[OpenSuse13.1] Pilote réseau manquant ? Empty Re: [OpenSuse13.1] Pilote réseau manquant ?

Message par Remuald le Sam 25 Jan 2014 - 19:37

monster a écrit:Avec le gestionnaire de package Yast il me semble (si je ne me trompe pas ^^')
Je viens d'utiliser cette méthode en passant depuis le menu Périphérique réseau puis Paramètres réseau et en configurant le MTU à 1500 + la config en DHCP et ça fonctionne :p.

J'accède maintenant à internet sans problème ^^.

Merci
Remuald
Remuald
Coadmin
Coadmin

Nombre de messages : 31630
Localisation : anywhere

Revenir en haut Aller en bas

[OpenSuse13.1] Pilote réseau manquant ? Empty Re: [OpenSuse13.1] Pilote réseau manquant ?

Message par sioban le Sam 25 Jan 2014 - 20:30

ben ton jme est présent, donc pas un problème de drivers quoi...
sioban
sioban
Coadmin
Coadmin

Nombre de messages : 21059
Localisation : Perdue dans les genres

Revenir en haut Aller en bas

[OpenSuse13.1] Pilote réseau manquant ? Empty Re: [OpenSuse13.1] Pilote réseau manquant ?

Message par Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Revenir en haut


 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum