Nantes Hardware
Connectes toi !

Installation debian/ubuntu sur UEFI

Page 2 sur 2 Précédent  1, 2

Aller en bas

Installation debian/ubuntu sur UEFI - Page 2 Empty Re: Installation debian/ubuntu sur UEFI

Message par Remuald le Dim 18 Sep 2011 - 14:02

quand je voulais faire le raid 5, j'avais 4 hdd et un cdrom de branché donc pas de souci ^^'

Remuald
Coadmin
Coadmin

Nombre de messages : 31630

Revenir en haut Aller en bas

Installation debian/ubuntu sur UEFI - Page 2 Empty Re: Installation debian/ubuntu sur UEFI

Message par sioban le Dim 18 Sep 2011 - 14:05

Ce n'est pas ce que tu dis :

j'ai fais une 1ere l'installation avec le raid5 actif mais en retirant 2 disque dur pour mettre mon lecteur cd. Après l'installation de l'OS, j'avais remis les hdd et virer le cdrom => pas moyen de booter (pb de uuid au grub).

Et ça réélement je suis persuadé que c'est corrigeable.
sioban
sioban
Coadmin
Coadmin

Nombre de messages : 21060
Localisation : Perdue dans les genres

Revenir en haut Aller en bas

Installation debian/ubuntu sur UEFI - Page 2 Empty Re: Installation debian/ubuntu sur UEFI

Message par Remuald le Dim 18 Sep 2011 - 20:16

on parle pas de la même chose :
  • installation avec os sur un hdd et raid 5
    ça ne fonctionne pas
  • installation os sur raid5
    ça ne fonctionne pas
  • installation os sur un hdd sans raid
    ça fonctionne
Remuald
Remuald
Coadmin
Coadmin

Nombre de messages : 31630
Localisation : anywhere

Revenir en haut Aller en bas

Installation debian/ubuntu sur UEFI - Page 2 Empty Re: Installation debian/ubuntu sur UEFI

Message par sioban le Dim 18 Sep 2011 - 20:21

Pas super clair...
Mais bon, je vais pas en installer un juste pour te prouver que c'est faisable...

Tu aurais été dans le coin, je serais venu et je pense qu'on aurait trouvé la solution.
sioban
sioban
Coadmin
Coadmin

Nombre de messages : 21060
Localisation : Perdue dans les genres

Revenir en haut Aller en bas

Installation debian/ubuntu sur UEFI - Page 2 Empty Re: Installation debian/ubuntu sur UEFI

Message par Remuald le Dim 18 Sep 2011 - 20:28

ouai enfin le principal c'est que j'ai un système fonctionnel

bon sinon je me rencontre que la reconstruction de raid pompe tout le cpu Sad
Remuald
Remuald
Coadmin
Coadmin

Nombre de messages : 31630
Localisation : anywhere

Revenir en haut Aller en bas

Installation debian/ubuntu sur UEFI - Page 2 Empty Re: Installation debian/ubuntu sur UEFI

Message par sioban le Dim 18 Sep 2011 - 20:30

ah bah ça... un raid logiciel hein ^^
Je ne sais pas si ça se règle
sioban
sioban
Coadmin
Coadmin

Nombre de messages : 21060
Localisation : Perdue dans les genres

Revenir en haut Aller en bas

Installation debian/ubuntu sur UEFI - Page 2 Empty Re: Installation debian/ubuntu sur UEFI

Message par Remuald le Mer 28 Sep 2011 - 22:53

Bon bein c'est un bug reconnu le problème d'installation de debian sur un système EFI :
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=455914

Une des solutions possible consiste à faire une partition de plusieurs dizaine de mo en fat 32 avec comme balise bios_grub et sans point de montage, le tout réalisé par gparted.
le tuto complet : http://www.cepcasa.info/blog/?p=192
Remuald
Remuald
Coadmin
Coadmin

Nombre de messages : 31630
Localisation : anywhere

Revenir en haut Aller en bas

Installation debian/ubuntu sur UEFI - Page 2 Empty Re: Installation debian/ubuntu sur UEFI

Message par sioban le Jeu 29 Sep 2011 - 8:59

Hum ça date de 2007 le bug, m'étonnerais qu'il soit encore d'actualité !
On dirait plus un soucis de GPT...
sioban
sioban
Coadmin
Coadmin

Nombre de messages : 21060
Localisation : Perdue dans les genres

Revenir en haut Aller en bas

Installation debian/ubuntu sur UEFI - Page 2 Empty Re: Installation debian/ubuntu sur UEFI

Message par xeno le Ven 30 Sep 2011 - 20:03

Super GRUB disk & Super GRUB2 Disk, j'ai jamais essayé.
Mais à priori cela aurait pu aider, à voir ici

http://www.supergrubdisk.org/super-grub2-disk/
xeno
xeno
NHFR addicted
NHFR addicted

Nombre de messages : 2801
Localisation : Blain

Revenir en haut Aller en bas

Installation debian/ubuntu sur UEFI - Page 2 Empty Re: Installation debian/ubuntu sur UEFI

Message par Remuald le Ven 30 Sep 2011 - 22:47

ok je vais regarder merci
Remuald
Remuald
Coadmin
Coadmin

Nombre de messages : 31630
Localisation : anywhere

Revenir en haut Aller en bas

Installation debian/ubuntu sur UEFI - Page 2 Empty Re: Installation debian/ubuntu sur UEFI

Message par Remuald le Lun 10 Oct 2011 - 23:56

je me reprend un mal de crane sur ce foutu serveur. depuis que je l'ai j'ai jamais pu l'utiliser -_-'.

j'ai mon raid 5 de 4 HDD de 3To chacun, sur lequel j'ai fais un partage samba.
et à coter j'ai un hdd de 500go, avec un autre partage samba.

sur ce dernier quand je copie 10k fichiers de 3-4Mo chacun, la copie se fait de 0 à 100%, parfait.

par contre si je copie la même chose sur un partage samba du raid, ça fige l'OS pendant plusieurs seconde, et ça le fait redémarrer.

d'après /var/log/syslog j'ai un problème avec la gestion du cache :
Code:
Oct 10 22:25:01 ServeurNAS /USR/SBIN/CRON[1953]: (root) CMD (command -v debian-sa1 > /dev/null && debian-sa1 1 1)
Oct 10 22:35:01 ServeurNAS /USR/SBIN/CRON[1957]: (root) CMD (command -v debian-sa1 > /dev/null && debian-sa1 1 1)
Oct 10 22:39:01 ServeurNAS /USR/SBIN/CRON[1962]: (root) CMD (  [ -x /usr/lib/php5/maxlifetime ] && [ -d /var/lib/php5 ] && find /var/lib/php5/ -type f -cmin +$(/usr/lib/php5/maxlifetime) -delete)
Oct 10 22:45:01 ServeurNAS /USR/SBIN/CRON[1969]: (root) CMD (command -v debian-sa1 > /dev/null && debian-sa1 1 1)
Oct 10 22:55:01 ServeurNAS /USR/SBIN/CRON[2026]: (root) CMD (command -v debian-sa1 > /dev/null && debian-sa1 1 1)
Oct 10 23:05:01 ServeurNAS /USR/SBIN/CRON[2058]: (root) CMD (command -v debian-sa1 > /dev/null && debian-sa1 1 1)

Oct 10 23:05:46 ServeurNAS kernel: [ 4584.311188] JBD: barrier-based sync failed on md126-8 - disabling barriers
Oct 10 23:06:00 ServeurNAS kernel: [ 4598.290449] JBD: barrier-based sync failed on md127-8 - disabling barriers

Oct 10 23:07:05 ServeurNAS kernel: [ 4663.621179] r8169: eth0: link up
Oct 10 23:07:07 ServeurNAS kernel: [ 4665.540284] r8169: eth0: link up
Oct 10 23:07:17 ServeurNAS kernel: [ 4675.280480] r8169: eth0: link up
Oct 10 23:07:18 ServeurNAS kernel: [ 4676.400290] r8169: eth0: link up
Oct 10 23:07:19 ServeurNAS kernel: [ 4677.396181] r8169: eth0: link up
Oct 10 23:07:22 ServeurNAS kernel: [ 4680.064279] r8169: eth0: link up
Oct 10 23:07:31 ServeurNAS kernel: [ 4689.292386] r8169: eth0: link up
Oct 10 23:07:34 ServeurNAS kernel: [ 4692.244444] r8169: eth0: link up
Oct 10 23:07:35 ServeurNAS kernel: [ 4692.917097] r8169: eth0: link up
Oct 10 23:07:40 ServeurNAS kernel: [ 4698.480425] r8169: eth0: link up

ce que j'ai pu trouver sur le net :
http://www.novell.com/support/search.do?cmd=displayKC&sliceId=SAL_Public&externalId=3907838

mon fstab :
Code:
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>  <type>  <options>      <dump>  <pass>
proc            /proc          proc    defaults        0      0
# / was on /dev/sda2 during installation
UUID=70bb4603-06df-4225-926e-8f6844a79886 /              ext3    errors=remount-ro 0      1
# swap was on /dev/sda1 during installation
UUID=2e23c144-fd5d-4de1-b7e8-952d07703cc0 none            swap    sw              0      0
/dev/scd0      /media/cdrom0  udf,iso9660 user,noauto    0      0

#partition logique pour jeux
UUID=52817d03-10da-43b5-a8ec-0d8efa66abb7      /games  ext3    defaults        0      0

#partition pour le stockage des donnees
UUID=52b60fa6-b16f-4f77-848a-de9093d0376f      /data  ext4    defaults        0      0

#partition pour partage
UUID=9c9f772d-c11d-45ac-be4d-a540f3f16632      /other  ext4    defaults        0      0

je pensais remplacer defaults par barrier=off ou ajouter l'option dans le grub (je ne sais pas comment Sad)

j'ai mis à jour me fichier /etc/mdadm/mdadm.conf
Code:
DEVICE /dev/sd[bcde]1 /dev/sd[bcde]2

ARRAY /dev/md127 uuid=63dea00f:37193ab3:8bb63ea2:2be88834 level=5 devices=/dev/sdb2,/dev/sdc2,/dev/sdd2,/dev/sde2
ARRAY /dev/md126 uuid=0726447f:b59c4a2f:e732a0b4:2255c9b1 level=5 devices=/dev/sdb1,/dev/sdc1,/dev/sdd1,/dev/sde1

ça change rien

ma question comment je peux désactiver barrier de façon définitive (valable après redémarrage) ? (en espérant que ça résolve mon pb ^^')
Remuald
Remuald
Coadmin
Coadmin

Nombre de messages : 31630
Localisation : anywhere

Revenir en haut Aller en bas

Installation debian/ubuntu sur UEFI - Page 2 Empty Re: Installation debian/ubuntu sur UEFI

Message par Remuald le Lun 10 Oct 2011 - 23:57

j'ai plus qu'a prendre mon cachet d'aspirine avant de me coucher, GG Sad
Remuald
Remuald
Coadmin
Coadmin

Nombre de messages : 31630
Localisation : anywhere

Revenir en haut Aller en bas

Installation debian/ubuntu sur UEFI - Page 2 Empty Re: Installation debian/ubuntu sur UEFI

Message par sioban le Mar 11 Oct 2011 - 8:45

Je ne sais plus Grub1 ou Grub2 finalement ?

** Dans grub1 c'est dans /boot/grub/menu.lst ou /boot/grub/grub.conf

cherche un truc du genre :

## ## Start Default Options ##
## default kernel options
## default kernel options for automagic boot options
## If you want special options for specific kernels use kopt_x_y_z
## where x.y.z is kernel version. Minor versions can be omitted.
## e.g. kopt=root=/dev/hda1 ro
## kopt_2_6_8=root=/dev/hdc1 ro
## kopt_2_6_8_2_686=root=/dev/hdc2 ro
# kopt=root=/dev/sda1 ro

et modifie la derniere ligne pour y ajouter barriers=off

puis update-grub

** Dans grub2 c'est dans /etc/default/grub ou /etc/grub.d que ça se passe

cherche GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

et ajoute barriers=off après le splash

Puis update-grub

Mais pour être certains que ce n'est pas un soucis, tu peux renvoyer la sortie de :
- cat /proc/mdstat
- mdadm -q -D /dev/md0
sioban
sioban
Coadmin
Coadmin

Nombre de messages : 21060
Localisation : Perdue dans les genres

Revenir en haut Aller en bas

Installation debian/ubuntu sur UEFI - Page 2 Empty Re: Installation debian/ubuntu sur UEFI

Message par Remuald le Mar 11 Oct 2011 - 9:28

Voilou :
root@ServeurNAS:~# vi /etc/default/grub
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet barriers=off"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_LINUX_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"
root@ServeurNAS:~# update-grub
Generating grub.cfg ...
Found linux image: /boot/vmlinuz-2.6.32-5-amd64
Found initrd image: /boot/initrd.img-2.6.32-5-amd64
done
root@ServeurNAS:~# cat /proc/mdstat
Personalities : [linear] [multipath] [raid0] [raid1] [raid6] [raid5] [raid4] [ra id10]
md126 : active raid5 sdb1[0] sde1[4] sdd1[2] sdc1[1]
471851520 blocks super 1.2 level 5, 512k chunk, algorithm 2 [4/4] [UUUU]

md127 : active raid5 sdb2[0] sde2[4] sdd2[2] sdc2[1]
8318932992 blocks super 1.2 level 5, 512k chunk, algorithm 2 [4/4] [UUUU]
[==================>..] resync = 93.4% (2590782316/2772977664) finish=61. 6min speed=49268K/sec

unused devices:
root@ServeurNAS:~# mdadm -q -D /dev/md127
/dev/md127:
Version : 1.2
Creation Time : Sun Sep 18 01:45:48 2011
Raid Level : raid5
Array Size : 8318932992 (7933.55 GiB 8518.59 GB)
Used Dev Size : 2772977664 (2644.52 GiB 2839.53 GB)
Raid Devices : 4
Total Devices : 4
Persistence : Superblock is persistent

Update Time : Tue Oct 11 08:30:55 2011
State : active, resyncing
Active Devices : 4
Working Devices : 4
Failed Devices : 0
Spare Devices : 0

Layout : left-symmetric
Chunk Size : 512K

Rebuild Status : 93% complete

Name : serveurnas:1
UUID : 63dea00f:37193ab3:8bb63ea2:2be88834
Events : 367

Number Major Minor RaidDevice State
0 8 18 0 active sync /dev/sdb2
1 8 34 1 active sync /dev/sdc2
2 8 50 2 active sync /dev/sdd2
4 8 66 3 active sync /dev/sde2
root@ServeurNAS:~# mdadm -q -D /dev/md126
/dev/md126:
Version : 1.2
Creation Time : Sun Sep 18 01:02:48 2011
Raid Level : raid5
Array Size : 471851520 (449.99 GiB 483.18 GB)
Used Dev Size : 157283840 (150.00 GiB 161.06 GB)
Raid Devices : 4
Total Devices : 4
Persistence : Superblock is persistent

Update Time : Tue Oct 11 06:25:55 2011
State : clean
Active Devices : 4
Working Devices : 4
Failed Devices : 0
Spare Devices : 0

Layout : left-symmetric
Chunk Size : 512K

Name : serveurnas:0
UUID : 0726447f:b59c4a2f:e732a0b4:2255c9b1
Events : 44

Number Major Minor RaidDevice State
0 8 17 0 active sync /dev/sdb1
1 8 33 1 active sync /dev/sdc1
2 8 49 2 active sync /dev/sdd1
4 8 65 3 active sync /dev/sde1
root@ServeurNAS:~#

c'est normal qu'il soit encore en resynchro, c'est depuis mon dernier message sur le fofo, il lui faut 10-12H pour resynchro Sad
Remuald
Remuald
Coadmin
Coadmin

Nombre de messages : 31630
Localisation : anywhere

Revenir en haut Aller en bas

Installation debian/ubuntu sur UEFI - Page 2 Empty Re: Installation debian/ubuntu sur UEFI

Message par sioban le Mar 11 Oct 2011 - 9:55

oki mais bon pas de failure.
un petit reboot pour le barriers et c'est bon ^^
sioban
sioban
Coadmin
Coadmin

Nombre de messages : 21060
Localisation : Perdue dans les genres

Revenir en haut Aller en bas

Installation debian/ubuntu sur UEFI - Page 2 Empty Re: Installation debian/ubuntu sur UEFI

Message par Remuald le Mar 11 Oct 2011 - 11:00

je fais le reboot dès que la synchro est finie Smile
Remuald
Remuald
Coadmin
Coadmin

Nombre de messages : 31630
Localisation : anywhere

Revenir en haut Aller en bas

Installation debian/ubuntu sur UEFI - Page 2 Empty Re: Installation debian/ubuntu sur UEFI

Message par Remuald le Mar 11 Oct 2011 - 12:07

Toujours le même bug et le même message :
Code:
Oct 11 11:45:08 ServeurNAS kernel: [  660.350627] JBD: barrier-based sync failed on md127-8 - disabling barriers
Oct 11 11:46:43 ServeurNAS kernel: [  754.804135] r8169: eth0: link up
Oct 11 11:46:43 ServeurNAS kernel: [  755.504581] r8169: eth0: link up
Remuald
Remuald
Coadmin
Coadmin

Nombre de messages : 31630
Localisation : anywhere

Revenir en haut Aller en bas

Installation debian/ubuntu sur UEFI - Page 2 Empty Re: Installation debian/ubuntu sur UEFI

Message par pmgamer le Mar 11 Oct 2011 - 12:26

Euh... FreeNAS Wink






J\'suis caché
pmgamer
pmgamer
NHFR All Stars
NHFR All Stars

Nombre de messages : 12433
Localisation : Nulle Part Ailleurs

Revenir en haut Aller en bas

Installation debian/ubuntu sur UEFI - Page 2 Empty Re: Installation debian/ubuntu sur UEFI

Message par sioban le Mer 26 Oct 2011 - 9:05

tiens remuald, kdo : https://linuxfr.org/news/uefi-%C3%A0-la-d%C3%A9couverte-du-nouveau-bios
sioban
sioban
Coadmin
Coadmin

Nombre de messages : 21060
Localisation : Perdue dans les genres

Revenir en haut Aller en bas

Installation debian/ubuntu sur UEFI - Page 2 Empty Re: Installation debian/ubuntu sur UEFI

Message par Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Page 2 sur 2 Précédent  1, 2

Revenir en haut


 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum